WordPress 2.9 ist da – Update ist erfolgreich fehlgeschlagen

Seit gestern steht WordPress 2.9 in den Startlöchern und viele haben schon erfolgreich geupdatet und berichten darüber wie toll es ist. Also habe ich auch nicht lange gezögert und auch ein Update gemacht. Die große neue Feature-Liste von WordPress 2.9 ist einfach zu verlockend um es nicht zu tun 😀

wordpress-logoAnfangs lief das Update auch sehr vielversprechend durch. Mein Blog und meine Admin Konsole waren weiterhin verfügbar. Also keine Probleme wie bei dem Update auf WordPress 2.8 🙂

Doch als ich dann mal versucht hatte einen Link auf meinem Blog zu öffnen ging es los. Der Link erschien zwar noch in der Adressleiste, aber es stand kein Inhalt dahinter. Eine weiße Seite bzw die Meldung, dass die Seite nicht erreichbar ist!

Seltsamerweise konnte man die Artikel in der Admin-Konsole bearbeiten und es war auch noch alles da. Auch in der Permalinkstruktur hatte sich nichts verändert. Es gibt auch keine Fehlermeldungen auf meinen Webserver Logs und auch von Extern bin ich nicht mehr über die direkten Permalinks erreichbar.

Der Cache war natürlich der erste verdächtige, aber leider brachte das deaktivieren des Plugins auch keinen Erfolg. Weiterhin blieben die Seiten einfach leer.

Für mich gab es daher wieder nur eine Lösung und das war der Stepback auf die vorherige WordPress Version. Das war auch nicht schwer, denn ich hatte natürlich das Verzeichnis von WordPress vorher gesichert. Bei der Datenbank musste man nicht mal eine Sicherung zurück spielen. Man kann die bestehende Datenbank weiter verwenden. Es kommt zwar eine Meldung, dass die Struktur geändert wird, aber danach funktioniert wieder alles in gewohnter Form 🙂

Für mich war es das erst einmal mit WordPress 2.9. Ich warte lieber ab, bis auch die Plugin Autoren neue Versionen, die auch WordPress 2.9 tauglich sind heraus gebracht haben. Vielleicht liegt es aber auch daran, dass ich einfach nur ein Theme habe, dass sich nicht mit WordPress 2.9 verträgt. So dramatisch sind die Änderungen auch nicht, das sich der Aufwand lohnt stundenlang nach dem Fehler zu suchen.

Habt Ihr noch vor ein Update zu machen, oder hattet ihr keine Probleme beim Update auf WordPress 2.9?

Für alle die es noch nicht gemacht und es noch vor haben rate ich dringend vorher wieder eine Sicherung des WordPress Verzeichnisses und der Datenbank zu machen. Man spart sich eine Menge Arbeit wenn das Update schief geht 😉

Diese Seite enthält affiliate Links. Für dich entstehen keine Mehrkosten, wenn du die verlinkten Produkte bestellt. Du unterstützt damit meine Arbeit und tust mit damit etwas Gutes.

Comments (61)

  1. Moin

    Bei mir klappte es ganz gut. Liegt vielleicht auch daran das ich kaum noch Addons habe..

  2. ich warte dann lieber noch. soll wohl auch Probleme mit Pingbacks geben.

  3. Danke für Deinen Bericht. Ich sitze schon den ganzen Tag hier und überlege, ob ich updaten soll oder nicht. Jetzt warte ich lieber noch etwas ab. 😉

  4. Oh, da bin ich ja froh, dass bei mir alles soweit ganz gut läuft.
    Nur der neue Image Editor funktioniert bei mir nicht. 🙁
    Es wird kein Bild angezeigt bzw. wird es nicht geladen und wenn ich auf die Werkzeuge klicke lädt es nur endlos lange und es passiert nichts. 🙁 Keine Ahnung an was das liegen könnte.

    Aber bisher gibs keine weiteren Probleme mit der neuen Version. 😛

  5. Ich wollte erst auf 2.8 updaten, aber hatte auch so meine Probleme damit… mal sehen.

  6. Ach bin ich froh das ich fast alles inzwischen selber progge und so kaum noch Plugins hab^^ Update manuel ohne Probleme bei mir. Jetzt muss ich nur noch die gaznen alten Vorschaubilder an das neue System anpassen. Mag nichts doppelt gemoppelt haben.

  7. Zwei Blogs – keine Probleme gehabt. Laufen beide auf den ersten Blick noch einwandfrei. Plugin Updates gab es vorher schon von einigen bei mir eingesetzten (Google Sitemaps, Google Analytics, DB Cache Reloaded, TinyMCE).

    Beste Grüße
    Lasse

  8. Ich habe das Update auch manuell durchgeführt und hatte dabei keine Probleme.

    Auch scheinen die (~40) Plugins normal zu funktionieren.

  9. Bei mir gabs diesmal auch wieder keine Probleme mit dem Update (zumindest bin ich noch über keine gestolpert)…

    Was mich aber wiedereinmal stört, der Speicherverbrauch ist wieder leicht gestiegen ca 0,5MB (von 32,5MB bei meiner Startseite auf 33MB) 🙁

  10. Automatisches Update. 39 Plugins und Thesis 1.6 Theme

    Lief glatt und war kein Problem. Bislang habe ich nichts merkwürdiges bemerkt, scheint alles gut zu laufen.

  11. Lief bei mir alles sauber.
    Habe ohne Backups ein Update von Hand gemacht und bis jetzt keine Probleme entdecken können… hoffen wir das beste. 🙂

  12. bei mir: keine Probleme 😀
    Ich hab aber auch keine so special-mäßige plugins laufen.

  13. so, ich habe es doch noch gewagt. Die Neugier siegt 🙂 scheint alles zu funktionieren :thumbsup:

  14. Lauft bei mir auch seit heute Mittag, bei mir auch ohne erkennbare Probleme.

  15. Uah, und ich Dussel habe vorher natürlich nicht gesichert und habe jetzt auch ein weisses Fenster, TOB! 🙁

  16. Pinkback: voxs photography » Wordpress 2.9

  17. Hallo Thomas,

    also bei mir klappte alles wunderbar. Als erstes ein Backup meiner kompletten Daten. Denn sicher ist sicher. Dann das löschen der alten und das einspielen der neuen Dateien. Bisher konnte ich noch keinen Fehler finden. Habe das meiste erfolgreich getestet und auch die Widgets/Plugins spielen alle mit.

    Gruß und schöne Feiertage

    Micha

  18. Also ich habe das Update auch gemacht….jedoch manuell weil es die letzten male nicht geklappt hat mit dem automatischen…ich habe sogar vorher vergessen eine Sicherung von meiner Datenbank zu machen…aber zum Glück hat es ja hingehauen. Also bis jetzt keine Probleme….noch nicht…

    Dominik

    PS: „core.php“ muss halt wie „immer“ geändert werden damit die Pingback und Trackback Funktion auch geht!

  19. Crazy Girl

    Hallo Thomas, das klingt aber übel. Konntest Du bereits eruieren woran es liegen könnte? Schau doch mal die My-SQL Version auf Deinem Server an. WP 2.9 braucht mindestans 4.1.2 und ich habe auch bereits 2 Pakete indentifiziert auf denen ich 2.9 nicht installieren darf, weil das installierte My-SQL niedriger ist.
    Dass das Theme nicht kompatibel ist, kann ich mir ehrlich gesagt nicht vorstellen. Hast Du z.B. mal das Standard Theme mit installiert und kurz gewechselt? So würdest Du sehen, ob es am Theme liegt, was ich aber nicht glaube. Die Themes verwenden für die Links ja die Link Funktion (ich glaube get_permalink und the_permalink) und die holt bzw. bastelt sich den Link ja aus der Datenbank zusammen und schreibt ihn via PHP um. Also ist in meinen Augen der Fehler eher in der Datenbank oder im entsprechenden umschreiben zu suchen, so dass nach dem Umschreiben nichts mehr aus der Datenbank kommt oder so.
    Vielleicht ist das ja ein Denkansatz, der weiter hilft. Ich glaube ich werde mich jetzt mal an einem Update versuchen. Drück die Däumchen

  20. @happy-buddha: Meinen Glückwunsch. Ja das kann gut sein.

    @Miracleworld: Dann hat sich bei dir die Neugierde gelohnt. Meinen Glückwunsch 🙂

    @Stefan: Hm ich scheine irgendwie der einzige zu sein, bei dem es nicht klappt. Claudi hat zwar auch den gleichen Fehler, aber der Großteil scheint mit dem Update sehr gute Erfahrungen zu haben.

    @Patrick: Das hört ich aber auch nicht gut an. Jedenfalls wäre das bei mir eine totale Katastrophe wenn es nicht gehen würde. Hast du schon mal versucht alle Plugins zu deaktivieren. Ich hatte auch mal das Problem mit einer älteren Version und da hatte ein Plugin den Fehler verursacht.

    @Chriz: Auf jeden Fall vorher eine Sicherung vom Verzeichnis machen. Dann kannst du auch ohne Probleme zurück schwenken, wenn was schief geht.

    @Markus: Das mit den Vorschaubildern ist schon eine feine Sache. Das wäre für mich einer der Hauptgründe. Im Moment habe ich so eine Lösung die zwar funktioniert aber mit der ich nicht ganz so glücklich bin. Wünsch die viel Erfolg beim proggen.

    @Lasse: Damit hattest du sozusagen Erfolg auf der ganzen Linie. Bei meinem anderen Testblog hat es auch sehr gut funktioniert. Aber da blogge ich auch nicht, sondern ist nur ein Test. Zwischen den Feiertagen werde ich es wohl in aller Ruhe noch einmal probieren. Im Moment ist nicht wirklich Zeit dafür.

    @Jeffrey: Mein Glückwunsch. Da scheinst du ja fast so viele Plugins zu haben wie ich 😉 Ich kann mir auch nicht vorstellen, dass ein Plugin diesen Fehler verursacht. Ich hatte sie ja auch schon alle deaktiviert. Es scheint nur eine Einstellung in meinem Webserver zu sein. Muss mal die Tage schauen. Es sollte auf jeden Fall zu lösen sein.

    @Olli: Mein Glückwunsch. Die 0,5 MB finde ich nicht so wild. Am Speicher mangelt es bei mir nicht. Aber irgend eine komische Einstellung scheine ich noch aktiviert zu haben.

    @Rosenkrieger: Na Sauber. Dann sage ich mal Glückwunsch zu dem erfolgreichen Update. Ich werde noch abwarten, ob noch so ähnliche Probleme wie bei mir bei anderen auftreten.

    @der sema: Ui das war aber riskant. Schön das noch alles läuft.

    @Flügel: Sehr schön. Ja mit weniger Plugins sind der Erfolgschancen eindeutig größer. Kann aber auch an einer Einstellung auf meinem Webserver sein.

    @Marco: Meinen Glückwunsch, dann sollte es auch weiterhin noch gut laufen 🙂

    @DasClaudi: Scheiße, dass ist natürlich blöd. Dann hilft nur noch die alte Version manuelle zu installieren. Wenn ich weiß woran es liegt werde ich darüber schreiben. Vielleicht konntest du auch schon den Fehler finden.

    @Michael: Meinen Glückwunsch. Scheint wirklich alles perfekt zu laufen. Und sehr schön das du vorher auch ein Backup gemacht hast.

    @Dominik: Da hattest ja echt ein großes Glück, dass alles so reibungslos geklappt hat. Ja die Pingback Funktion muss man leider komischerweise immer noch selber fixen obwohl es doch schon längst bekannt sein müsste.

    @Tanja: Leider habe ich schon überall die neusten Version. mysql bin ich auf 5.x und auch bei Apache bin ich auf der neusten Version. Ich glaube auch nicht mehr das des Problem in dem Theme zu suchen ist. Ich habe ja den Permalink auch in der URL stehen wie er sein sollte. Komischerweise baut er nur die Seite nicht auf. Das Seltsame ist ja auch, dass im Index.php auch alle Posts angezeigt werden. Es besteht also nur in der Single.php das Problem, dass die Posts nicht angezeigt werden können.
    Ich werde mir zwischen den Feiertagen das alles mal genauer anschauen. Im Moment ist es zeitlich so eng und ich habe morgen auch noch eine wichtige Prüfung. Daher habe ich das Update erst einmal auf Eis gelegt. Wäre nur zu schön gewesen, wenn es gleich geklappt hätte 😉

  21. Crazy Girl

    Ich glaube ich muss Dich auch gleich nochmal demotivieren. Ich bin gerade drüber über den Update und alles sieht gut aus. Keine leeren Seiten etc. Jetzt noch die alten Anpassungen und dann kann ich den Blog wieder frei geben.
    Hmm… das mit der My-SQL Version wäre zumindest eine Möglichkeit gewesen. Nur die single.php… das ist ja auch doof. Wie gesagt, wenn Du es nochmal versuchst, einfach mal eines der Standard Themes aktivieren und dann sehen, ob dort das gleiche Problem besteht. So kannst Du zumindest eruieren wo die Problematik liegt, an WordPress selbst oder am Theme bzw. den Plugins die Du über die single.php ansprichst. Könnte ja auch sein, dass da ein Plugin die Grätsche macht und gleich alles versaut.
    Vor Weihnachten ist das natürlich eine wirklich dumme Zeit. Kaum einer ist jetzt mit Zeitüberschuss bedacht.
    Ich drück Dir die Daumen für die Prüfung morgen :thumbsup:

  22. Pinkback: Crazy Girls Tipps

  23. Pinkback: Gesichtet: Das Fundstück der Woche (32) – Infos zu WordPress 2.9 und Google | GESICHTET.net

  24. Ich hatte mit dem Update auch gar keine Probleme ;).

  25. Mein erster Impuls nach dem Lesen war, ich warte noch. Nach den Kommentaren warte ich nicht. Aber erst mal ein Backup. Sicher ist sicher…

  26. Backup ist ja eine Selbstverständlichkeit.
    Ich warte eigentlich immer (wenn auch nur kurz), um die Reaktionen bei den ersten „Updatern“ mitzubekommen.
    Mit dieser Vorgehensweise bin ich eigentlich immer sehr gut gefahren und werde es wohl auch zukünftig so handhaben.

  27. Bei mir lief das Update (welches ich manuell durchgeführt habe) ohne Probleme ab.

  28. Ich habe das Update noch nicht versucht. Da es anscheinend öfters Probleme damit gibt, werde ich erstmal abwarten und auf ein weiteres Update warten. Danke für deinen Bericht!

    Grüße
    Dennis

  29. Ich teste das Update jeweils auf einer Kopie meines Blogs. Wenn da alles ok ist, lass ich das Update auch auf der Version laufen, welche die Besucher zu sehen bekommen. Hat bisher immer funktioniert. Allerdings, Fehler können sich auch da einschleichen wenn man die eine oder andere Funktion nicht genau so testet wie es ein Besucher benutzt.

  30. So, das update lief gestern ohne Probleme 🙂

  31. @Tanja: Du bist gut demotivieren. Ich freue mich doch für alle die es schaffen ein Update zu machen. Bis jetzt kenne ich einschliesslich mehr auch nur 5 bei dennen es nicht geklappt hat. Da aber gestern auch sehr viele Google Suchergebnise zu dieser Seite gefunden hatten werden es auch weit noch mehr sein. Mit dem Update 2.8 hatte ich ja auch eine Menge Probleme. Nachdem ich mich in einer freien Minute länger damit auseinander gesetzt hatte, ging es dann. Ich denke schon, dass ich es nächste Woche hin bekomme.
    Danke für Daumen Drücken hatte in der Prüfung 975 von 1000 Punkten. Eine Frage habe ich blöderweise falsch beantwortet.

    @Lordy: Perfekt :thumbsup:

    @Crosa: Na meinen Glückwunsch. Ja es scheinen wohl nur Einzelfälle zu sein, aber es gibt noch einige mehr davon und das beruhigt mich ein bisschen und lässt nicht an meinen Fähigkeiten zweifeln 😉

    @Jens: Backup ist keine Selbstverständlichkeit. Ich kenne viele, die keines machen und die wird es immer geben. Aber dein Weg ist auch wirklich der beste. Auch bei 2.8 hatte es ja nicht lange gedauert bis ein 2.8.1 raus gekommen ist.

    @Thomas: Super :thumbsup:

    @ZZipp: Ich glaube es ist nie verkehrt erst einmal ein bisschen abzuwarten und zu beobachten, wie die Erfahrung anderer User ist. So lange es auch kein Systemkritisches Update ist sollte man sowieso lieber etwas warten.

    @Marcosan: Das ist die perfekte Lösung und ich mache es genauso. Ich nenne einfach nur die Verzeichnise um, starte meinen Webserver und wenn es nicht klappt, dann werden die Verzeichnisse wieder zurück getauscht. Ich könnte jetzt auch wieder innerhalb von Sekunden auf 2.9 wechseln, aber dann hätte ich halt wieder das alte Problem 😀

  32. Ich habe eigentlich schon vor ein Update zu machen. Allerdings ist meine MySQL Version einen Tick zu alt. Mein Hoster ermöglicht es zwar auf die aktuellste Version umzustellen, allerdings wird das nur für Datenbanken bis maximal 5 MB empfohlen. Die Datenbank von meinem Blog ist doch ein ganzes Stückchen größer.

    Ich habe jetzt doch erstmal ziemlich kalte Füße bekommen und werde wohl noch eine Weile warten, auch wenn es natürlich ziemlich reizt jetzt schnell das Update zu machen. Denn jeder schreibt ja nun darüber und bringt erste Tipps/Tricks zu „Carmen“ raus. Scheiss Technik *g*

    LG Piet

  33. @Piet Das Problem mit der DB Größe lässt sich denk ich umgehen. Mach ein Backup mit mysqldumper. Lösch die Datenbank, lass MySQL updaten und spiel dann das Backup bei Bedarf wieder ein. So würde ich vorgehen.

  34. @Markus Danke für den Tipp. So würde ich wohl auch vorgehen, aber das ist der Punkt wo ich kalte Füße bekommen. Zum einen hab ich dann möglicherweise eine Downtime von einigen Stunden, zum anderen bin ich total unsicher ob das wiederaufspielen der Datenbank dann wirklich fehlerfrei funktioniert. Habe soetwas schon mehrmals gemacht früher, in 90% der Fälle ging auch alles glatt. Aber wie ich mich kenne kriege ich zu Weihnachten die 10% Chance und werde die Feiertage fluchend am PC verbringen… *g*

  35. @zzipp Das warten auf ein weiteres Update bringt dir meines erachtens gar nichts. Die meisten Probleme resultieren durch Plugins, Server Configs und ähnliches. Das wird auch durch ein weiteres Update nicht behoben. Bei einem weiteren Update wird nur weniger über Probleme berichtet, da a) die meisten diese Probleme dann schon behoben haben und b) viele auch auf das dann wahrscheinlich wieder verfügbare Upgrade Packet zugreifen das auch weniger Probleme bereitet. Den einzigsten Vorteil den du durch warten hast ist das evtl. einige Plugins dann updates wiederfahren haben und kompatible sind.

  36. @Piet Die Downtime lässt sich eigentlich auch im Griff behalten.

    1. Backup per mysqldumper machen.
    2. Hoster um Update von MySQL bitten und evtl. eine Benachrichtigung erhalten per Mail oder Telefon wenn das Update von deren Seite durchgeführt wurde.
    3. Prüfen ob alles noch läuft, wenn ja -> wirklich erstmal alles durchtesten. Wenn nein -> Schritt 3a.
    3a. Backup der Datenbank einspielen und nochmal Schritt 3 durchgehen.

    Eine Downtime hast Du dann im schlimmsten Fall nur wenn während des Updates Deine Datenback einen Schuß bekommt. Wenn nicht ist die Downtime nur so lang wie eben das Update von MySQL dauert und das sollte nicht viel sein.

    Schritt 4 vielleicht erst in 1 oder 2 Tagen dann das WP Update angehen.

    Wenn Du die Möglichkeit hast kannst ja auch nach Schritt 1 nochmal auf einer anderen Datenbank das Backup 2-3 mal einspielen um zu schauen ob es hinhaut. Ich arbeite jetzt schon seit Jahren mit mysqldumper und kann mich nicht erinnern das mir jemals ein Backup kaputt ging. Mit phpmyadmin hingegen hatte ich sehr oft Probleme, wobei die auch nur auftraten wenn die phpmyadmin Version verschieden war.

  37. Ich musste zwei mal updaten. Das erste Mal war die Sprache Englisch (trotz installierter DE- Version) und nun scheint es geklappt zu haben. Einziges was ich komisch finde: Ein paar Felder wie z.B. „Vorschau der Änderungen“ sind noch abgerundet, andere eckig, irgendwie eigenartig.

  38. Du hast aber auch ein Pech bei den Updates 🙁
    Bei mir läuft es seit zig Versionen einwandfrei und immer innerhalb von Minuten…
    Mittlerweile halte ich es frei nach Linus Torvald „only wimps use backup“, lach…

    Ist bzw. war die Seite auch leer, wenn alle Plugins deaktiviert waren?

  39. Bei mir hat das Update auf allen Blogs problemlos geklappt.

    Leider muss man aber auch in der aktuellen Version wieder den Pingback/Trackback Bug fixen: http://blog.knut.me/2009/12/wp-technik-2-9-und-die-pingbacks/

  40. @Piet: 5MB Begrezung. Da bin ich mit 120 MB auch schon weit drüber. Ich habe den Vorteil, dass mein Server auch wirklich mir gehört und ich auch dafür komplett verantwortlich bin. Das hat natürlich auch den Nachteil, dass ich dann rennen darf, wenn er Kaputt ist. Dieser Update Button verlockt wirklich und ich bin auch schon ganz wild auf einige der neuen Funktionen. Dann könnte ich auch ein paar Plugins raus werfen, die dann überflüssig werden. Aber man sollte sich dennoch Zeit und Ruhe nehmen. Mal schnell sollte man in dem Fall nicht machen. Es kann gut gehen, aber es kann eben auch voll in die Hose gehen und dann kommt man auch schnell ins Schwitzen. Die Tatsache, dass ich auch schon von vielen Leuten gehört hab, dass es nicht geklappt hat beweist, dass es zu Problemen kommen kann.

    @Markus: Ob da der Hoster immer so mitmacht? Viele werden bestimmt nicht einfach so mal die sql Version updaten bzw Einstellungen ändern.

    @Julia: Das hört sich aber komisch an. Ich kenne das nur, dass was im Firefox und im Safari rund ist, ist im IE eckig, weil es nicht unterstützt wird. Aber freut mich für dich, dass es geklappt hat. Ich würde es ja auch nicht mal so schlimm finden, wenn meine Sprache englisch wäre.

    @Marc: Stimmt bei den Updates hatte ich bis jetzt immmer Probleme. Ich glaube ich sollte lieber die Finger von WordPress lassen 😀
    Ja auch bei allen deaktivieren Plugins hatte ich das Problem. Ich glaube da ist irgendwo im Theme noch der Wurm drin. Das seltsame ist ja wirklich, dass die URL in der Adresszeiele steht, aber nichts kommt und das im Index alle Artikel angezeigt werden. Daher geht ja auch die Datenbankabfrage. Während den Feiertagen werde ich etwas Zeit investieren.

    @Gilly: Ich glaube schon gar nicht mehr das es ein Bug ist. Immerhin ist das schon über ein Jahr bekannt.

  41. @ Ja machen vielleicht nicht alle, kommt natürlich auch auf den Hoster an. Aber in Piets Fall bietet es der Hoster ja auch an. 🙂

  42. @hombertho – deine Blog-DB hat 120 MB?!

  43. Ja die lieben Statistik Plugins und anderes 🙂 Meine DB hat gerade mal 20 MB. 120 ist schon ne Haufen. Ich denke mal da sind gut 60% von Stats und ungenutze Reste?

  44. @Marc: Ja aber da sind sehr viele Altlasten drin. Wie Markus bereits vermutet hat sind es viele Statistik Plugins dran schuld. Aber auch das steht auf meiner ToDo Liste 😉

    @Markus: Ja damit hast du recht und ich werde demnächst auch mal komplett die Datenbank ausmisten. Dann sollte sie auf jeden Fall schlanker werden und auch wieder perfomanter.

  45. Habe gestern abend den Schritt gewagt, von 2.7 auf 2.9 upzudaten. Zunächst einmal mit WP Database Backup die Datenbank gesichert (geht schnell und einfach, < 5 Minuten), dann mit Filezilla die gesamte Dateistruktur per Drag-und-Drop auf meinen Rechner kopiert. Dauerte ca. 10 Minuten mit DSL 6000.

    Dann in WP das AutoUpdate angeworfen und nach 30 sec. war mein WP auf dem neuesten Stand! Lediglich 2 Plugins machten Zicken (Pagebar2 und Broken Link Checker), aber nachdem ich die deaktiviert hatte, lief alles wunderbar. Und Pagebar 2 gibt es jetzt auch in einer neuen Version, die prima mit WP 2.9 funktioniert.

    Summa summarum hat mich die Aktion incl. Testen ca. 1 Stunde gekostet und alles läuft super.

  46. Schade, das Dein Update nicht funktioniert hat. :gruebel:
    Ich trau mich (noch) nicht und warte noch. :whistling:

    Dir und Deinen Lieben schöne Festtage und frohe Weihnachten.

    Liebe Grüße,
    Michaela

  47. @Martin: Mein Glückwunsch, dass es so Reibugslos funktioniert hat. Pagebar 2 benutze ich gar nicht und broken Link checker hatte ich deaktiviert. Funktionier bei mir aber blöderweise nicht. Ich warte bis noch ein paar Plugins aktualisiert werden. Gerade in letzter Zeit gibt es für fast jedes Plugin einen neue Version.

    @Michaela: Ist nicht so schlimm. Irgendwann bekomme ich das auch noch hin 😉
    Das gleiche wünsche ich dir und deiner Familie. Habt eine schöne ruhige und besinnliche Zeit.
    lg
    Thomas

  48. Pinkback: Neuerungen und Problemloesungen in Wordpress 2-9 | Internet und Webpromotion

  49. Hi,
    das hatte ich mitunter auch, aber ich habe dabei vorerst nicht dem neuen WP die Schuld gegeben. Jedoch ist es Stunden später nach dem üblichen Hin-und-Her-Fummeln im Blog sowie dem WP-Backend passiert und ich musste das neue Update als Ursache ansehen.

    Ich habe dann alles Mögliche probiert und unter den Einstellungen zu WP-SuperCache stand ein PHP-Codeschnipsel, welcher wohl in die .htaccess eingefügt werden sollte. In der WP 2.8.6 musste ich ihn entfernen, weil es ein Problem mit dem Cache gab. Hier habe ich es wieder eingefügt und dann waren die Blogseiten und Beiträge wieder da.

    Das Krasseste war ja, dass die Inhalte hinter keinem Bloglink mehr da waren und ich hatte mich ganz schön erschrocken, wollte gar nicht glauben, was ich da wieder gemacht habe.

    Ob das die wirkliche Ursache für das Problem war und ich es nur durch Code-Einfügen lösen konnte, kann ich nicht beweisen, weil ich das bisher nicht kannte und kann den Fehler nicht mal reproduzieren. Das Problem war dann einfach wieder behoben.

    Manchmal kommt es im WP zu Fehlern, welche man gar nicht nachvollziehen kann.

  50. Ich habe das Update auf 2.9 nicht gemacht und werde es nach diesem Artikel auch erst mal dabei belassen.

    Ich warte also gespannt der Dinge.
    Gruß

  51. @Ronny WP 2.9.1 Beta 1 ist ja schon erschienen 🙂

  52. Hallo. Also ich hatte bisher keine sichtbaren Probleme. Einzig allein das Plugin Simple Tags wollte nicht so, konnte aber durch einen kleine Änderung zum laufen überredet werden. Vielleicht habe ich nur lange genug gweratet bis die meisten Plugins ihre updates veröffentlicht hatten 😉

    Allen ein frohes Fest …

  53. ja nach einem Serverumzug und einem update auf 2.9 funktionieren die links nicht mehr die home zwar schon. auch wenn ich einen neuen Artikel verfasse lässt sich dieser auch nicht über view ansehen.
    hmm jemand eine idee dazu. permalinkstruktur habe ich belassen.
    lg

  54. @Alex: Danke für den Hinweis. Super Cache habe ich nicht installiert, aber ich werde noch einmal eine komplett Leere WordPress Installation machen und dann auch alles nach und nach in das neue Verzeichnis kopieren. Bei mir ist leider das Theme teilweise so verstrickt, dass ich nicht alle Plugins deaktivieren kann. Ansonsten würde sich die Seite überhaupt nicht aufbauen.
    Schade. Ich möchte es wirklich einmal erleben, dass ein Update gleich sofort klappt.

    @Ronny: Tja die Erfahrungen sind eher gemischt. Wobei es wohl Einzelfälle sind, bei denen es nicht klappt.

    @Stefan: Glückwunsch zum erfolgreichen Update. Mittlerweile gab es wirklich schon sehr viele Updates für einzelne Plugins. Leider geht mein Update auf Version 2.9 immer noch nicht. Da muss ich wohl noch ein bisschen weiter suchen, bis ich den Übeltäter gefunden habe.

    @Fred: Das hört sich fast nach meinem Problem an. Leider habe ich bis jetzt noch keine Lösung gefunden.

  55. @hombertho,
    was ich schon oft feststellen musste, dass die WP-Updates sich von Blog zu Blog anders verhalten. Manche Blogs kommen mit einem Update besser zurecht als die anderen und da ich auch schon mehrere WP-Themes im Blog hatte, ist auch noch theme-abhängig.

    Ich hatte bei den letzten zwei Updates kaum ein Plugin deaktiviert gehabt, einfach neue Installation raufgezogen und gut. Aber sowas kann auch ins Auge gehen:).

    Derzeit ist die Beta 1 von 2.9.1 im Umlauf und mit jedem Update verschwinden auch die Bugs. Ich bleibe zuversichtlich.

  56. @Alex: Gut dann werde ich am besten auf die Version 2.9.1 warten. Vielleicht klappt es dann mit dem Update. Manchmal macht ja auch das Zusammenspiel von Plugins Probleme. Einzeln funktionieren sie wunderbar und sobald man sie kombiniert, dann geht gar nichts mehr.

  57. Pinkback: Wordpress 2.9 Update vollbracht - BlogFrosch

  58. Pinkback: WordPress: 2.9 – Keine Probleme beim Update… > Backup, Update, WordPress > splash ;)

  59. Bei mir läuft es wieder *freu*. Und ich habe am WordPress gar nichts mehr geändert. Aber ich habe seit Weihnachten einen neuen Compi. Wie immer auch das WordPress in Kontakt mit Firefox, Computer und Co steht, es scheint ihm jetzt besser zu gefallen. :thumbsup:
    LG Claudi

  60. hombertho

    @DasClaudi: Super. Dann lag es wohl nur am lokalen Cache des Browsers, dass deine Seite nicht richtig anzeigt wurde.

  61. Pinkback: Wordpress 2.9 Update glücklich vollzogen | Crazy Girls Tipps

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind mit * markiert.